(click on row to see topic details)
   ContentFounderRepliesViewsLast message
Page size:
 22 items in 2 pages
Topic Before submitting an issue, please check our FAQ section.
George 01441
Topic It appears there is a server down.  The emulator has stopped working for all games.   Dan Maren 169 2/10/2018 9:29:00 AM
Topic I just downloaded Fable, but I can't play it because it is asking for a cd. I thought that the cd was with it, or am I mistaken? Rob Califf 1509 12/6/2015 4:58:00 PM
Topic I'm having several problems with the online Warlords 2 Deluxe. When we escape the blue player chat screen and go into the game. I am the only one who gets redirected to the 'Checking to make sure all players are in the same version screen.' Everyone else's screen just turns black. Alex Richards 0593
Topic Hi,

I´ve downloaded the good old Warcraft 1 using this link and it works fine except for the fact that the starting file deletes itself everytime I launch it (which seems to be intentional). However I´ve spent a few hours already using the integrated DOS Box (I think the program is called Emulator Starter) and now I´d like to use my WC1 save game files. Where are the needed files for the game stored so I can access these save games or does anyone know where the files themselves are?
kridas 1730 10/8/2015 4:57:00 PM
Topic Hi, I can't run the CD-rom version of Fantasy General on your website, but I can run the non-cd rom version (but I wan't the cd-rom one).

I also tried downloading it and manually emulating it on my computer, but I'm not getting any sound whatsoever.

I tried both Google Chrome and IE, neither seems to be doing the job.

Is there anyone out there who could help me play this great game with decent voiceover?

Thanks a lot!

Edit: The dos screen flashes for a second and says something about the path not being valid...?
Barna Beres 1791 10/6/2015 5:25:00 PM
Topic i cant access my Castle of the winds save game when starting castle of the winds 2, i love that you guys have these old games, but would really like to be able to continue my character AJ Thomas 2891 11/6/2014 9:56:00 PM
Topic Full screen after Alt-Tab.

Hey, Im trying to play on here but Ive had issues since I started using this site that when I Alt-Tab out of my games (since they start in full screen0 I cant find a way to enter back into fullscreen mode. Alt-Enter has had no effect so far.
Mitchell Anderson 1926 10/15/2014 10:05:00 AM
Topic Hi there. I just have an issue with playing the Alter Ego (Female) version in browser - is it impossible to reach the icons on the side that will indicate stats, options of jobs, college classes, finding romantic partners, etc.? The arrow keys (nor anything else I have tried) have not led me to click on those buttons to do an action there; I can only access the basic nodes. As the other boxes are rather vital to the game, I'm feeling a keen lack :(
Does anyone know if this is simply an ingame issue, or am I missing out on an instruction?
Katie L. 01007
Topic I'm trying to play a game and I clicked the Play Now(ClickOnce) button and it brings up the emulator installer, but when it goes to install it tells me I can't run the emulator independently and to pick a game to play. What am I doing wrong???? Aley Laird 31693 5/2/2014 7:08:00 PM
Topic I am trying to play pool of radiance.   I am using click once.   It works find and I can save games etc...problem is~
I can not find ANYWHERE on my computer where it is storing this data.  It said documents and settings/user name/application data....
there is no such thing as application data or anything like that folder in ANY of my user folders in documents and settings...where is it???
Jessie Lucky 21251 5/2/2014 7:12:00 PM
Topic Deleting saved games on Kings Bounty

Hi - does anyone know how to delete games for Kings Bounty?  Whenever I try to play it tells me I have the maximum number of saved games and to delete some or load saved game.  How do you delete saved games?  Loading games doesn't help as all of them are at a point right at the end of the game, so you can't start from scratch.

I've tried uninstalling and reinstalling but it still remembered me and the saved games.

Eve Kendall 21401 5/2/2014 7:13:00 PM
Topic I don't even know if anybody is maintaining this site anymore, but i seem to have a bit of a problem.  I just beat champions of krynn through your website and was trying to move on to the next game : Deathknights of krynn.  however it wont let me load my save from the first game. it keeps saying 'error : cannot find champs folder'.   I've checked online and have tried many differant things, like copying the champs folder and just moving it into the deathknight folder, or makeing a new folder at c:cok, or c:champs  and moving the save files there.. nothing seems to be working =(  i hope you can help out, i'd really like to finaly be able to play all 3 games.  thanks in advance Riftweaver81 31441 5/2/2014 7:14:00 PM
Topic I'm encountering problems with all Java applet buttons when running IE. Eveything on my computer Java and IE have been reinstalled. The problems still exist. I'm thinking it may be a problem on you end. Who knows thou. The buttons include Download/Play Now/Topic....

thanks for the look, and all the new RPG's
BadPuppy 21446 5/2/2014 7:18:00 PM
Topic I´m trying to play UFO:Enemy Unknown on my win7, it work´s fine, xcept I´m not able to change framerate nor cycle up with ctrl f11 ( my first dosboxgame, dunno if it´s just the UFO game or all games,,,) , configuring the dosbox 0.74 options has no effect, the cycle keeps being too fast, on 40000 by default.
Is there a way to change this, I can´t play the game time running like day in a minute and ppl walking fast as hell

LeMarchant 21411 5/2/2014 7:19:00 PM
New Topic